読者です 読者をやめる 読者になる 読者になる

そのボード、僕が積んでおきます。

たくさんの電子工作基板が積みっぱなしになってるので、頑張って工作しようとしていますが、どんどん溜まっていっております。

極小LinuxボードVoCoreで遊ぶ【復旧?!編】

しつこいようですが続きます。

 

初boot→WiFi接続→Webから管理ツールLuciにアクセス(ちなみに初期のパスワードはvocoreだよ)→公式の注意書きでLuciでは設定するな→しょうがないからsshで接続して様子を見る→先日ビルドしたFirmwareを試してみよう→LuciからFirmwareの更新→再起動完了→再度WiFiで接続→でもWebアクセスができなくなった(Luci不在)→sshで接続を試みるもパスワードがわからない→どうやらrootパスワードは未設定の様子→telnetでloginできるらしい→telnetでloginしpasswdコマンドでパスワード設定→sshでの接続に切り替え→Luci探すも入ってなさそう→Firmwareの再ビルド→scpしてからmtbコマンドでFirmware書き換え→再起動→WiFi消えたー!→Firmwareの再ビルド→シリアルコンソール接続→kermitでFirmware転送→Firmware書き換え失敗→bootすらせず(イマココ)

 

ってことで、さらに復旧を目指します。

昨晩の最後のメッセージは

U-Boot for VoCore(based on RT5350)Warning: un-recognized chip ID, please update bootloader!
..
Version: May 30 2014 20:52:36
Press 'x' to console...

Booting image at bc050000 .Bad Magic Number,FFFFFFFF

でした。

これをGoogle先生に聞いてみます。

 

出てきました。またもやVoCoreの中の人のblogのForumです。

Topic: I can't flashing the *.bin file | Vonger's Blog

#1085
vonger
vonger
Keymaster

Hi, that is ralink uboot bug, please try to call tftpboot before cp.linux(use Ctrl+C to cancel that tftpboot process). After that, you can go cp.linux 2c0004

  • This reply was modified 3 months, 2 weeks ago by vonger vonger.

えええええええ!さきにtftpboot一度打っとけとか気がつかないし!ということで、cp.linuxする前に、

tftpboot

って打ってから、Ctrl-cで抜けてからやればいける、ということでした。

 

そして、せっかくなのでFirmwareのbuildのやり直しをちょっと変えてみました。

make menuconfig

の時にLuciのメニューが出ているはずなので、そこでLuciのパッケージのインストールをきちんと選ぶことであったり、uhttpdもbase packageのhttp/proxyから選んでおく必要がありそうです。

 

この辺をオンにしてbuildすると、VoCoreのWikiにある通りのバイナリサイズになりました。これか!

 

ということで、やっとFirmwareの書き換え完了。

 

でも、まだWiFiは出てきません。これはこれでコンソールからちゃんと設定する必要がありそうです。

ただ、先ほどのForumでいい記事を見かけました。

 

Topic: WLAN connection at your home WiFi | Vonger's Blog

VoCoreをWiFiの子機として設定する方法です。いや、どっちかというとこっちを探してましたよ!ということで、早速設定です。

 

まずは、networkの設定を書き換えます。

vi /etc/config/network

こんなふうに書いて保存

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
 
config globals 'globals'
        option ula_prefix '***:****:****::/48'
 
config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.61.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr ':'
 
config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
 
config switch
        option name 'rt305x'
        option reset '1'
        option enable_vlan '1'
 
config switch_vlan
        option device 'rt305x'
        option vlan '1'
        option ports '0 1 2 3 4  6t'
 
config switch_vlan
        option device 'rt305x'
        option vlan '2'
        option ports ' 6t'
 
config interface 'wlan0'
        option hostname 'OpenWRT'
        option proto 'dhcp'

「***」のところは自分の設定ファイルの内容を活かしたり、自分の環境に直してください。

次に、wirelessの設定の書き換えです。

vi /etc/config/wireless

 このように書き換えます。適宜読み替えてください。

config wifi-device  radio0
option type 'mac80211'
option hwmode '11g'
option path '10180000.wmac'
list ht_capab 'GF'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
option htmode 'HT20'
option txpower '0'
option country 'JP'

config wifi-iface
option device 'radio0'
option ssid '********'
option mode 'sta'
option network 'wlan0'
option encryption 'psk2'
option key '********'

これだけ設定をいれて立ち上げ直したら、家のWiFiに接続し、DHCPでIPが振られました。これで、SSHでログインできます。例によってtelnetでパスワードの設定をするのを忘れないように。

 

ってことで、WiFiルータの機能は現時点では消えますが、WiFiでインターネットに接続する小型Linuxボードになりました!